PC extreme lag, slow image build-up during/after (re)boot


Might as well see if any of you guys have and idea what’s going on with my PC.
I’m kinda at my wit’s end here with a problem I couldn’t find any solutions (or even similar cases) online.

System Specs:

Windows 10 Pro 21H2 OS Build 19043.1348 / Windows Feature Experience Pack 120.2212.3920.0
Ryzen 3700X w/ Noctua NH-D15 (AM4)
Asus X470 Crosshair 7 Hero Wifi (UEFI v. 4603, latest one currently)
G.Skill Trident Z 2x 8GB 3200MHz CL14
MSI RX 480 Gaming X 8GB
Seasonic Prime Platinum 850W

no OC applied, only Asus’ stupid enhancer thing disabled that maxes out PPT etc

tl;dr - Sometimes upon (cold / re-) booting my PC will lag extremely. Mouse cursor if laggy and unprecise and opened windows (everything new popping up on the display) will slowly build up from top to bottom.
Also, sometimes my mobo will not post but hand at Asus’ Q Code “07” - AP Initialization after microcode loading.

This started about a week ago. My PC suddenly went out and when I powered it on again it would be stuck before post with a q code showing up on the diagnostic led (with the vga led lit up). I hit the reset button and it posted/booted as usual.
Then the trouble with the lag started. Sometimes a reboot fixed that, sometimes my mobo would get stuck before posting and I had to hit the reset button, sometimes it would just take forever to post/boot without any intervention.

I suspected the latest AMD GPU driver to be the culprit and rolled back to a previous version, which seemed to fix the problem but now it has started again.
This issue will also occur in safe mode with no chipset/gpu drivers installed. Randomly. Sometimes there is lag, sometimes there isn’t. Doesn’t seem to make a difference if it’s in safe mode, safe mode + network, normal windows boot.
IF it works, it works.
No BSODs, no black screens (other than before posting, don’t know if those count). No crashes.

One other thing that I noticed is that sometimes my GPU’s memory clock gets stuck at 300MHz. The solution to that also only works sometimes (setting the min/max in Radeon and applying each change individually), today it required a wipe/fresh install of the GPU driver to a newer one.

I have no idea if this is somehow related, but as of today some of my USB ports stopped working (they get power, but no data and Windows doesn’t recognize any device plugged in). Tried uninstalling the individual host controllers but to no avail (AMD 3.10 eXtensible Host Controller - 1.10 (Microsoft) didn’t show up again after a reboot and USB xHCI Compliant Host Controller shows up with the same yellow triangle again, updating driver doesn’t fix it).

I have no idea what causes this problem. Is it a bug in the latest BIOS version, is it my GPU, is it the motherboard, software or something entirely different?

I hope someone is much smarter than I am and can help figuring this out.

If any additional info is required please let me know.

edit: for some fucking reason that is unknown to me cause it all seems completely random, the USB ports are working again. I have no clue why.

1 Like

my gut reaction is that the BIOS is possibly bugged or corrupted, I’ve had somewhat similar issues to these before and reflashing the BIOS helped and may want to try that or even downgrading it if possible.If that doesn’t help with the amount of issues you are having personally I’d probably just reinstall Windows.

1 Like

I’ll try the previous BIOS version then.

Both of your suggestions are on my list of things I can do, although the BIOS reflash is much higher up since a fresh installation of Windows would require several hours of setting things back up again (which I’m dreading and pushing off as last attempt).

edit: nope, that didn’t do the trick. right after flashing back to the previous version and posting it lagged again. reflashed again cause…who knows? might’ve been borked again. nah. after that was done and my PC restarted it was even slower than before. hit the reset button to enter the bios and load my profile, then saw there’s some tpm crap in the previous version that’s not in the current one and it has a ton of stuff enabled by default. maybe that stuff is slowing my pc down? idk, I really have no clue what is going on at this point.

1 Like

Over on asus forums they mentioned it might be to do with ram training failing (ram not keeping its clock and settings etc). Could be the ram itself or the controller on the cpu. Either would be annoying but try swapping around the memory to see if different slots do anything. If not could see if the cpu is under warranty still and talk to the support for it and see if the problem persists what they can do about it.

There’s a small chance it could be the motherboard but a few people in similar situations still had issues even after a mobo swap, that would be the easiest way to tell if it’s the cpu having a problem though

1 Like

So, if it’s a RAM issue, does this happen after several years of daily use with the same settings?
I mean, it’s not as if I didn’t have RAM suddenly shit the bed after previously testing it with Memtest.

And I’d prefer it being the CPU over the mobo cause I actually still have warranty on the CPU and a new mobo would be expensive.

How do I check if it’s RAM then? Just letting Memtest run for a few hours with each stick individually?

And I could test if it’s the CPU cause I still got my 1700…if that one isn’t faulty too cause I had some issues when I was still using the 1700…which makes the mobo seem more likely to be the culprit.

In that case swap cpus to see if it’s just the 3700x, the controller for memory might have died (or is dying) and may explain some of the seemingly random other things failing and then working if it’s iffy.
But if you change ram slots or just do one at a time that is a way to test those, that and memtest.
If the 1700x behaves the same as the 3700x and it’s a known good chip it’s probably motherboard (after you try the ram to eliminate that)

1 Like

I’ll try Memtest first and swap the CPU tomorrow. I’ve been going at this issue for about 9h today and I’m exhausted (not counting the time I’ve spent previously). Should eat something too.

What irks me is the randomness.
I can sometimes start the PC and it behaves as it should. Other times it hangs before post and requires the push of the reset button. Then it will work and the issues occur the next time I reboot or after the 2nd reboot.
But when there’s no issue once booted up it will keep working like normal. So my assumption is that there’s something going wrong before the mobo posts.

edit: quick unimportant update to the process: I just saw that I have 3 years warranty on my mobo. bought it Dec 10 2018, so I have a little under 4 weeks left to take advantage of that IF the mobo turns out to be faulty. the 3700x was bought earlier this year, so there’s still enough warranty time left. ram should still be under warranty (whatever their “lifetime warranty” means).

if none the memtest stuff shows anything wouldnt be that surprised if gpu, but not sure anything could do to test it really other than turn on the onscreen w.e. fps/clocks etc in the driver and hope that kicks in while its still loading the stuff to see if clocks or utilization are doing anything weird

source: playin random easy ass mmo to run(mabinogi) but when it switches from login to actually in game it doesnt have vsync or somethin for the little bit its initalizing and everything else pauses like video playing drops to like 5fps, cause game doing like white screen at 15k fps or somethin

gotta try update my driver tho on one from maybe couple months ago(dont play any super new out games other than back for blood which has ps4 graphics so that runs easy already)

is it slow forever or just white its finishing bootin up w.e.?

edits: obv sounds maybe somethin more serious for the not booting right etc part

If it’s slow before/during post/boot, then it’s also slow on desktop. The only thing that fixes it is a reboot. Or two or more. Until eventually it will post/boot normally.
It’s also not the same amount of slow the every time. Plus, in BIOS it will register keystrokes multiple times and execute them delayed (the amount of delay also varies).

On to the update: since yesterday Memtest86 has finished 15 passes over a time of ~12h with 0 errors. I tested with both sticks installed rather than each individually cause I’ve read that testing individual sticks is only necessary to figure out which of the sticks is faulty (or if both are).

The next thing I did was unplug all the HDDs/SSDs, swap my m.2 OS drive with the new one that’s been collecting dust in a cupboard for months and do a fresh installation on a new drive. During the initial setup (selecting drive/partitio, language/region/etc.) the lag was still present, which seemed to rule out a faulty Windows install or drive. But after it finished the installation and rebooted a couple of times, the only issue I had was a blackscreen one time when I switched keyboard language (no drivers installed, no software, nothing. right after installing Windows). Since then, nothing. And I rebooted/cold booted several times. I also connected the other drives again and installed drivers and some software.

I have no fucking clue what the cause was. I’m still in the process of testing hardware. Tomorrow I’ll swap the old OS drive back in (with the other drives disconnected) and see how it behaves. Then CPU, GPU, each RAM stick individually for 1-2 passes (errors should pop up if one’s really faulty) and I ordered a PSU tester which should arrive tomorrow.

But after everything I’ll probably buy a new mobo and try to send the current one in for RMA while I still have warranty.

I’ve been advised to play some demanding games to check stability, rather than using synthetic benchmarks or stress test software.
So this is my task for today. And setting up all the software I had installed.

ye sometimes weird shiz happens hard to say exactly

What I can say by now is that the m.2 / Windows installation wasn’t the cause of this cause after half a day of working perfectly fine this fucking issue happened again. Even worse than before cause this time I got a BSOD as well (Clock_Watchdog_Timeout).

I don’t want people to be right and it turning out to be the GPU…

Detailed update:

So I swapped the m.2 yesterday and did a fresh installation of Windows 10. During the installation the lag/slow image build-up occurred again but after my PC rebooted a couple of times during the installation it seemed fine. Fine and for long enough for me to think the issue has been solved. And it worked fine for half a day with several reboots and some cold boots.

But the issue occured again at night after powering on the pc after several minutes of being shut off (extension cord was switched on during the time pc was powered off).

  • Q code 62 + white led (Installation of PCH Runtime Services, white led = VGA), led turns off after a few min, 62 remains monitors are turned on (backlight) but black.
  • after several minutes q code changes to 98 + green led (Console Input devices connect, green led = boot).
  • after ~10min q code switches to Ad with no led (Ready To Boot event) but nothing happens.
  • unplugged DP cable from GPU and boot logo with loading animation shows up on 2nd monitor (is connected via DVI). very!!! slow (slowest I’ve ever seen it behave so far), q code AA (System has transitioned into ACPI mode. Interrupt controller is in APIC mode). un/plugged DP cable again. no change. plugged DP cable in 2nd DP port → logo + loading animation shows up on 1st monitor too. animation goes on for several minutes until the loading animation disappears, only logo remains (did it freeze up?)
  • Reset button → normal speed post but slow boot loading animation only showing on 1st monitor
  • BSOD - Clock_Watchdog_Timeout (got a memory dump)
  • restarts into windows repair screen. attempt repair, fails (q code still AA). boot into windows as if nothing happened.
  • Notification pops up “Radeon Watt Man has been reset”.
  • Event Viewer shows Bug Check (memory.dmp saved)
  • Windows Memory Diagnostic Tool. Automatic reboot after finished, no issues (no errors in WMDT or lag during post/boot)
  • Win Update (just the Xbox Wireless Adapter driver), reboot normal
  • Notification pops up that WMDT has found no errors during the test.

I called it a night after that and turned my PC off.
In the morning when I powered my PC on again the screens stayed black (backlight on) for longer than it usually would when it posts/boots normally, so I hit the reset button and it started normal.
This is the current state. I’m writing the update right now on my PC, but I’m sure the issue will occur again.

I have a PSU tester coming in today and “just to be sure” I ordered a new mobo, even though it might not be the cause. But the mobo and RAM are the only components I don’t have spares of to swap out an test. This means more component swapping today to make sure whatever causes the issue doesn’t damage my new mobo. I really hope it’s not the GPU. While I do have my old R7 260X…it’s outdated but at least my PC would be usable until I get a new one (who knows when that will be with the current GPU situation).

Didn’t do much in terms of testing today, only software stuff (meaning one pass of 3DMark Time Spy, CPU Profile and Stress Test) as I mainly backed up my stuff to my ext. HDDs. And tbh, as much as I want to get to the source of this problem, I’m exhausted and just wanted to take it slow today.

The 3DMark runs were stable and the results good. Which makes me think that the CPU, GPU and PSU aren’t likely the source of this. Could be wrong. I’ll see.

I got the PSU tester and it looks like it’s made of Chinesium. Being cautious, I tested it with my old PSU first. Seems to work well, so tomorrow I’ll test my current PSU with it.
Should’ve done this years ago but I’ve also ordered an anti-static wrist strap in order to not fuck up my new mobo the day it arrives. And some USB flash drives cause the ones I have are already in “use” (Gparted, Memtest, linux distros, Windows installation, Hiren’s, latest bios version for flashing, etc).

So tomorrow I’ll tackle this problem again and try different things like only using one stick of RAM at a time, test PSU, swap CPU, GPU and try my old PSU.

The issue occurred today as well when I first powered on my PC. Hit the reset button and it posted/booted just fine and I’ve been using it the whole day (didn’t do any reboots, though, so there never was a chance of the issue occurring anyway other than during when I turned on my PC).

Update: the issue still persist. Two days in a row, though, I was able to boot - the very first cold boot of the day - without the issue occurring. But eventually, maybe during the first or second or third reboot (right click start menu button → shutdown or sign out → restart) it will occur again.

My lazy and expensive “plan” is that I ordered a new mobo (has arrived), new ram (comes on monday) and a new psu (comes on tuesday, cause tbh I don’t trust my old psu anymore, the 5y warranty is long over). That gives me a spare to test and swap of every component except for my int. HDDs and assuming my old Ryzen 1700 has no faults.
Then I’ll take my current PC apart, install the new hardware and put the old one in my old case to test components (each ram stick individually, swap cpu, gpu).

Would there be a cheaper, easier way? idk. when something with my main pc is wrong that I just can’t seem to figure out I get anxiety.

What if the GPU turns out to be the cause? Well, fuck me, I guess. I entered the queue on EVGA’s to be notified if a 2060 Ultra or 1660 Super are available (not ideal, not gonna be cheap with import tax shit cause they ship from Taiwan, but better than the overpriced hell that is the current GPU market).
What if it’s the CPU? Also not ideal. I can probably still use my 1700, but a replacement for my 3700x from Amazon doesn’t seem likely right now cause they’re out of almost ALL Ryzen 3000 and 5000 series CPUs. But for a refund I can shell out more and get one again from another place, or go current gen, empty my GPU fund and get a 5800X.
If RAM is fine, I’ll send the new kit back.
If the Mobo is faulty I’ll need to hurry and get Asus to approve an RMA cause usually my warranty would be over. Only still applies to me cause I bought it less than 3 years ago (have like almost 3 weeks left).

What I can rule out right now are the NVMe SSD and Windows cause the issue persisted even after putting a new SSD in and installed Windows fresh.
But the fact that the issue shows up at/before post and persists to the desktop sure isn’t helping.
And there’s the crackling/zapping sound (not a popping sound) that was audible when my PC suddenly went out when the issue first started (never happened again after that one time).
And it sure doesn’t help that my PC seems very stable once it posted/booted without the issue occurring. Can play games, watch Twitch/YT, run 3DMark (GPU benchmark, CPU profile and stresstest) and AMD’s own stress test in Radeon.

like when poor connection on a speaker sometimes?(does popping too but the intermittent cutting out crackly static)

stuff like that could def be psu noise, or mobo, usually failing caps etc

but should be able to test for that when all the stuff shows up

You mean like when you plug a cable into a speaker/amp and it crackles along with some static humming?
Hm…not quite. Definitely some crackling but a bit more sparky. And no popping at all. More like “electricity frying something”, if that makes sense.

ye kinda usually is like staticy/crackle then when you touch it the wire connects or somethin and then it pops usually

but usually speaker amps and stuff the hum is 50/60hz so wouldnt be that kind of hum/noises with pc since switchmode power supplies at much higher frequency, would be more like coil whine or somethin prolly

but dont always hum if caps are failing, course could always be somethin else failing too

Yeah, well, I took the expensive route and ordered a new mobo, ram and psu.
Last part should arrive on tuesday, so that’s then I’ll continue testing hardware.

Got the psu cause I noticed my old spare S12ii-620w (even though I only replaced when I had the issue with the x370 gigabyte board) is 7 years old now and a few years over warranty.
The new mobo, since if my C7H faulty RMAing would take ~2 weeks. I couldn’t find anything about extended warranty after repairs through RMA, so that means if it fails again I’d have to get a new one anyway.
And the RAM cause…well, same as the mobo.
Plus, we’re starting a new lockdown here on Monday, so all non-essential stores are closed, which shifts purchases of electronic devices to online orders. And with limited inventory (might not be able to get a kit for a reasonable price that’s on the list of supported memory, or any at all) from online shops here, and Christmas coming up (which also means increased number of orders), it would probably take longer.

The only two things that might be (or certainly are) difficult to get a replacement of are the CPU (Amazon Germany doesn’t have the 3700X in stock (with no note when/if it will be available again), so I’d get a refund and would have to get it from somewhere else. Hell, Amazon Germany has basically no Ryzen 3000/5000 CPUs in stock right now. And the other one is a GPU. Cause fuck those prices. So I have to settle for my old R7 260X and Ryzen 1700 for testing.

ye dunno

Update: for quite a few days I’ve been dragging my feet and instead of actually testing components I tried to do the irrational thing of throwing money at the problem.
Since then I got new RAM (unopened), a new PSU (still sitting in the box) and ordered 2 different mobos and had one of them replaced, cancelled the replacement to get a refund and ordered a 3rd one (all without actually testing to see if it’s my current mobo that’s causing the issue).
Now, the 3rd mobo is in shipping limbo. I ordered it when the listing said “ready to ship in 1-3 days” but after ordering the listing says “1 in stock” but the order button is gone. Meanwhile the delivery date in my order confirmation email says “we’ll email you when we know when it’s gonna ship”, so…this is where I am now.

I’ll pick up testing components again and depending on what I can conclude I might even cancel that mobo order and send back the RAM (probably gonna keep the PSU, depends on what I can find out about my issue and hardware relation).

Trying to throw money at the problem didn’t get me one step closer to finding out what is actually wrong with my PC cause I just put it off (“I’ll test shit once everything has arrived”).
Yeah, definitely the wrong approach.

ye oh well lel. hopefully is one of the things